Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-729

LP:998028 - Server crashes on normal shutdown in closefrm after executing a query from MyISAM table

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.1.67, 5.2.14, 5.3.12
    • Component/s: None
    • Labels:

      Description

      #4  <signal handler called>
      #5  0x082fe139 in closefrm (table=0x937bbd8, free_share=true) at table.cc:2019
      #6  0x082e7acd in intern_close_table (table=0x937bbd8) at sql_base.cc:793
      #7  0x082e7b73 in free_cache_entry (table=0x937bbd8) at sql_base.cc:815
      #8  0x08738d04 in my_hash_delete (hash=0x8a63720, 
          record=0x937bbd8 "\270\302\067\tp\a9\t\260\304\070\t8\334\067\t") at hash.c:566
      #9  0x082e7daf in close_cached_tables (thd=0x0, tables=0x0, have_lock=false, 
          wait_for_refresh=false, wait_for_placeholders=false) at sql_base.cc:877
      #10 0x082e6430 in table_cache_free () at sql_base.cc:142
      #11 0x082916ca in clean_up (print_message=true) at mysqld.cc:1367
      #12 0x0829151f in unireg_end () at mysqld.cc:1307
      #13 0x082914a7 in kill_server (sig_ptr=0x0) at mysqld.cc:1242
      #14 0x082914be in kill_server_thread (arg=0xaeaf7388) at mysqld.cc:1270
      #15 0xb779fb25 in start_thread () from /lib/libpthread.so.0
      
      maria-5.1
      bzr version-info
      revision-id: <email address hidden>
      date: 2012-04-24 17:29:03 +0200
      revno: 3147
      

      Also reproducible on maria-5.2 revno 3149.
      Could not reproduce on maria-5.3 revno 3519, maria-5.5 revno 3397, mysql-5.1.63.

      # Test case
      # If you use the client,
      # - start server with --core or --log-error;
      # - execute SQL below;
      # - stop server using mysqladmin shutdown (or sending SIGTERM).
      # if you run it via MTR, just make sure you don't have a result file with the same name as the test file.
      
      DROP TABLE IF EXISTS t1;
      CREATE TABLE t1 (a INT, b VARCHAR(1), KEY(b,a)) ENGINE=MyISAM;
      INSERT INTO t1 VALUES
      (1,'a'),(2,'b'),(3,'c'),(4,'d'),(5,'e'),
      (6,'f'),(7,'g'),(8,'h'),(NULL,'i');
      SELECT MIN(a), b FROM t1 WHERE a=7 OR b='z' GROUP BY b;
      

        Gliffy Diagrams

          Activity

          ratzpo Rasmus Johansson added a comment -

          Launchpad bug id: 998028

          serg Sergei Golubchik added a comment -

          pushed in 5.1


            People

            • Assignee:
              serg Sergei Golubchik
              Reporter:
              elenst Elena Stepanova
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 1 hour
                1h