innodb_compression_algorithm configuration variable can be set to unsupported value

Description

We should check is LZ4 and/or LZO installed and if not do not allow to use respective values on configuration variable. Similarly innodb_compression_algorithm_basic.test should be fixed to work when LZ4 and/or LZO is not installed.

Environment

None

Assignee

Jan Lindström

Reporter

Jan Lindström

Labels

Fix versions

Affects versions

Priority

Minor
Configure