libmariadb requires libss.so.1.0.0 (OPENSSL_1.0.0)

Description

I’m currently using MariaDB C Connector 2.2 and it has a dependency on OpenSSL 1.0.0 (libssl.so.1.0.0 with version definition OPENSSL_1.0.0).

[root@server5088-vm07 2.2.0]# ldd reporter

./reporter: /root/2.2.0-redhat/./libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /root/2.2.0-redhat/./libmariadb.so.2)
libmariadb.so.2 => /root/2.2.0-redhat/./libmariadb.so.2 (0x0019e000)
libssl.so.1.0.0 => /root/2.2.0-redhat/./libssl.so.1.0.0 (0x0021c000)
[stuff del]

Why? All OpenSSL 1.0.x releases are binary compatible (https://www.openssl.org/docs/faq.html#MISC8).

In addition my RH release ships with OpenSSL 1.0.1 and there should be no reason I need to maintain 2 versions of OpenSSL. Any guidance would be appreciated.

[root@server5088-vm07 2.2.0-redhat]# objdump -p libssl.so.1.0.0 | grep OPENSSL_
3 0x00 0x066a2b21 OPENSSL_1.0.1
4 0x00 0x02b21533 OPENSSL_1.0.1_EC
0x02b21533 0x00 08 OPENSSL_1.0.1_EC

[root@server5088-vm07 2.2.0-redhat]# ls -al
total 1756
drwxr-xr-x. 2 root root 4096 Oct 9 10:10 .
dr-xr-x---. 12 root root 4096 Oct 9 10:04 ..
r-x-----. 1 root root 1281934 Oct 9 10:05 libmariadb.so.2
lrwxrwxrwx. 1 root root 25 Oct 9 10:10 libssl.so.1.0.0 -> /usr/lib/libssl.so.1.0.1e
r-x-----. 1 root root 507756 Oct 9 10:05 reporter

Environment

None

Assignee

Georg Richter

Reporter

John Muller

Labels

None

Affects versions

Priority

Major
Configure